ProcessIFCProject Method (IFCAnyHandle)


The entry point to the native IFC import function. Processes the main IfcProject and creates appropriate Revit elements.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void ProcessIFCProject(
	IFCAnyHandle ifcProject
)
Visual Basic
Public Sub ProcessIFCProject ( _
	ifcProject As IFCAnyHandle _
)
Visual C++
public:
void ProcessIFCProject(
	IFCAnyHandle^ ifcProject
)

Parameters

ifcProject
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The IfcProject containing the entities in the IFC file.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also