ProcessIFCProject Method (IFCAnyHandle)


Importer IFC Process IFCProject(IFCAny Handle) Method

The entry point to the native IFC import function. Processes the main IfcProject and creates appropriate Revit elements.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ProcessIFCProject(
	IFCAnyHandle ifcProject
)

Parameters

ifcProject IFCAnyHandle
The IfcProject containing the entities in the IFC file.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also