AreElementsValidForCreateParts Method


Identifies if the given elements can be used to create parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool AreElementsValidForCreateParts(
	Document document,
	ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function AreElementsValidForCreateParts ( _
	document As Document, _
	elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool AreElementsValidForCreateParts(
	Document^ document, 
	ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
elementIds
Type: System.Collections.GenericICollectionElementId
Element ids to be tested for validity for creating parts.

Return Value

True if all member ids are valid, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also