AreElementsValidForCreateParts Method


Part Utils Are Elements Valid For Create Parts Method

Identifies if the given elements can be used to create parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool AreElementsValidForCreateParts(
	Document document,
	ICollection<ElementId> elementIds
)

Parameters

document Document
The document.
elementIds ICollection ElementId
Element ids to be tested for validity for creating parts.

Return Value

Boolean
True if all member ids are valid, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also