The view id that will be used to generate the preview.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
InvalidElementId signals that there is no permanent preview view for the document. Where possible the document's active view will be used to generate the preview upon save; where there is no active view the document will not include a preview.Remarks
This view will always be saved as the preview view for the document unless it is overridden by the value used in SaveOptions or SaveAsOptions.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | When setting this property: The view id is not valid to use as a preview view. |
Autodesk.Revit.ExceptionsArgumentNullException | When setting this property: A non-optional argument was null |