Document |
The view id that will be used to generate the preview.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Property Value
ElementIdInvalidElementId signals that there is no permanent preview view for the document. Where possible the document's active view will be used to generate the preview upon save; where there is no active view the document will not include a preview.

Exception | Condition |
---|---|
ArgumentException | When setting this property: The view id is not valid to use as a preview view. |
ArgumentNullException | When setting this property: A non-optional argument was null |

This view will always be saved as the preview view for the document unless it is overridden by the value used in SaveOptions or SaveAsOptions.