SetAnchorPoint Method


Sets the reference that determines the origin of this DisplacementPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void SetAnchorPoint(
	DisplacementElement displacementElement,
	Reference reference,
	double param
)
Visual Basic
Public Sub SetAnchorPoint ( _
	displacementElement As DisplacementElement, _
	reference As Reference, _
	param As Double _
)
Visual C++
public:
void SetAnchorPoint(
	DisplacementElement^ displacementElement, 
	Reference^ reference, 
	double param
)

Parameters

displacementElement
Type: Autodesk.Revit.DBDisplacementElement
The element id of a DisplacementElement.
reference
Type: Autodesk.Revit.DBReference
A reference of an edge or a curve in the GRep of the element corresponding to elemId.
param
Type: SystemDouble
An parameter used to specify a point on the edge.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The value param should lie in the range [0,1]. -or- reference does not represent an edge or curve belonging to an element displaced by displacementElement.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also