SetAnchorPoint Method


Displacement Path Set Anchor Point Method

Sets the reference that determines the origin of this DisplacementPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetAnchorPoint(
	DisplacementElement displacementElement,
	Reference reference,
	double param
)

Parameters

displacementElement DisplacementElement
The element id of a DisplacementElement.
reference Reference
A reference of an edge or a curve in the GRep of the element corresponding to elemId.
param Double
An parameter used to specify a point on the edge.
Exceptions
Exception Condition
ArgumentException The value param should lie in the range [0,1]. -or- reference does not represent an edge or curve belonging to an element displaced by displacementElement.
ArgumentNullException A non-optional argument was null
See Also