GetBoundingElementsForSpaceVolume Method


Returns the collection of bounding building elements for an enclosed space volume.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public IList<LinkElementId> GetBoundingElementsForSpaceVolume(
	int spaceVolume
)
Visual Basic
Public Function GetBoundingElementsForSpaceVolume ( _
	spaceVolume As Integer _
) As IList(Of LinkElementId)
Visual C++
public:
IList<LinkElementId^>^ GetBoundingElementsForSpaceVolume(
	int spaceVolume
)

Parameters

spaceVolume
Type: SystemInt32

Return Value

The ids of the bounding building elements for the enclosed space volume.

Remarks

This method requires the building envelope analyzer method created with the option set to compute enclosed space volumes.

See Also