SketchedStairsCurveData Constructor


Construct a SketchedStairsCurveData defined by a curve associated with its height and slope type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public SketchedStairsCurveData(
	Curve boundaryCurve,
	double height,
	SketchedCurveSlopeOption slopeType
)
Visual Basic
Public Sub New ( _
	boundaryCurve As Curve, _
	height As Double, _
	slopeType As SketchedCurveSlopeOption _
)
Visual C++
public:
SketchedStairsCurveData(
	Curve^ boundaryCurve, 
	double height, 
	SketchedCurveSlopeOption slopeType
)

Parameters

boundaryCurve
Type: Autodesk.Revit.DBCurve
height
Type: SystemDouble
slopeType
Type: Autodesk.Revit.DB.ArchitectureSketchedCurveSlopeOption

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also