Sketched |
Construct a SketchedStairsCurveData defined by a curve associated with its height and slope type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public SketchedStairsCurveData(
Curve boundaryCurve,
double height,
SketchedCurveSlopeOption slopeType
)
Parameters
- boundaryCurve Curve
- height Double
- slopeType SketchedCurveSlopeOption

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |