A copy of the ExportLayerInfo item that corresponds to the layer's ExportLayerKey.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- layerKey
- Type: Autodesk.Revit.DBExportLayerKey
Return Value
A copy of the ExportLayerInfo for the layer Key.Remarks
When getting this property, it returns a copy of the ExportLayerInfo from the table. In order to make changes to the ExportLayerInfo and use those settings during export, set the modified ExportLayerInfo back into the table using the same key.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | When getting this property: An entry with the given key is not present in the table. |