Item Property


Export Layer Table Item Property

A copy of the ExportLayerInfo item that corresponds to the layer's ExportLayerKey .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExportLayerInfo this[
	ExportLayerKey layerKey
] { get; set; }

Parameters

layerKey ExportLayerKey

Return Value

ExportLayerInfo
A copy of the ExportLayerInfo for the layer Key.
Exceptions
Exception Condition
ArgumentException When getting this property: An entry with the given key is not present in the table.
Remarks
When getting this property, it returns a copy of the ExportLayerInfo from the table. In order to make changes to the ExportLayerInfo and use those settings during export, set the modified ExportLayerInfo back into the table using the same key.
See Also