Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- solidGeometry
- Type: Autodesk.Revit.DBSolid
The geometry to analyze.
- plane
- Type: Autodesk.Revit.DBPlane
The plane to use for the base plane for the extrusion.
- direction
- Type: Autodesk.Revit.DBXYZ
The direction to use for the calculation for the extrusion. The direction must be transverse to the base plane.
Return Value
The newly created ExtrusionAnalyzer object.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The input direction must be transverse to the input plane. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | A failure occurred in creating the ExtrusionAnalyzer or computing the solid's shadow. |