Create Method


Extrusion Analyzer Create Method

Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ExtrusionAnalyzer Create(
	Solid solidGeometry,
	Plane plane,
	XYZ direction
)

Parameters

solidGeometry Solid
The geometry to analyze.
plane Plane
The plane to use for the base plane for the extrusion.
direction XYZ
The direction to use for the calculation for the extrusion. The direction must be transverse to the base plane.

Return Value

ExtrusionAnalyzer
The newly created ExtrusionAnalyzer object.
Exceptions
Exception Condition
ArgumentException The input direction must be transverse to the input plane.
ArgumentNullException A non-optional argument was null
InvalidOperationException A failure occurred in creating the ExtrusionAnalyzer or computing the solid's shadow.
See Also