Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- externalId
- Type: Autodesk.Revit.DBExternalGeometryId
The ExternalGeometryId of the requested reference object.
Return Value
A Reference to the externally tagged reference GeometryObject having the provided external ID or a null reference (Nothing in Visual Basic) if there is no reference geometry having the external ID.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |