Direct |
Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- externalId ExternalGeometryId
- The ExternalGeometryId of the requested reference object.
Return Value
ReferenceA Reference to the externally tagged reference GeometryObject having the provided external ID or if there is no reference geometry having the external ID.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |