LayerModifier Constructor (ModifierType, String)


Constructs a new LayerModifier with modifierType and separator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public LayerModifier(
	ModifierType modifierType,
	string separator
)
Visual Basic
Public Sub New ( _
	modifierType As ModifierType, _
	separator As String _
)
Visual C++
public:
LayerModifier(
	ModifierType modifierType, 
	String^ separator
)

Parameters

modifierType
Type: Autodesk.Revit.DBModifierType
The modifier type.
separator
Type: SystemString
The separator string that will follow this modifier in the export layer name.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The provided separator contains invalid characters (most special characters are invalid).
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also