NewAreaTag Method


Creates a new area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AreaTag NewAreaTag(
	ViewPlan areaView,
	Area room,
	UV point
)
Visual Basic
Public Function NewAreaTag ( _
	areaView As ViewPlan, _
	room As Area, _
	point As UV _
) As AreaTag
Visual C++
public:
AreaTag^ NewAreaTag(
	ViewPlan^ areaView, 
	Area^ room, 
	UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DBViewPlan
The area view
room
Type: Autodesk.Revit.DBArea
The area to tag
point
Type: Autodesk.Revit.DBUV
The position of the area tag

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the area view does not exist in the given document.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the area does not exist in the given document.

See Also