IsCurveFromOtherElementSketch Method


Identifies if the given curve element is generated by another element's sketch, or if it represents an independent curve element accessible directly by the user.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool IsCurveFromOtherElementSketch(
	CurveElement curveElement
)
Visual Basic
Public Shared Function IsCurveFromOtherElementSketch ( _
	curveElement As CurveElement _
) As Boolean
Visual C++
public:
static bool IsCurveFromOtherElementSketch(
	CurveElement^ curveElement
)

Parameters

curveElement
Type: Autodesk.Revit.DBCurveElement
The curve element.

Return Value

True if the curve element was generated by a sketch, false if it is independent.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also