IsCurveFromOtherElementSketch Method


Exporter IFCUtils Is Curve From Other Element Sketch Method

Identifies if the given curve element is generated by another element's sketch, or if it represents an independent curve element accessible directly by the user.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsCurveFromOtherElementSketch(
	CurveElement curveElement
)

Parameters

curveElement CurveElement
The curve element.

Return Value

Boolean
True if the curve element was generated by a sketch, false if it is independent.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also