IsValidExternalGeometryIdForNewCorrespondence Method


Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public bool IsValidExternalGeometryIdForNewCorrespondence(
	ExternalGeometryId externalGeometryId
)
Visual Basic
Public Function IsValidExternalGeometryIdForNewCorrespondence ( _
	externalGeometryId As ExternalGeometryId _
) As Boolean
Visual C++
public:
bool IsValidExternalGeometryIdForNewCorrespondence(
	ExternalGeometryId^ externalGeometryId
)

Parameters

externalGeometryId
Type: Autodesk.Revit.DBExternalGeometryId
The ExternalGeometryId to be used in a new correspondence.

Return Value

True if the input ExternalGeometryId can be used to create a new correspondence.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also