IsValidExternalGeometryIdForNewCorrespondence Method


BRep Builder Persistent Ids Is Valid External Geometry Id For New Correspondence Method

Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidExternalGeometryIdForNewCorrespondence(
	ExternalGeometryId externalGeometryId
)

Parameters

externalGeometryId ExternalGeometryId
The ExternalGeometryId to be used in a new correspondence.

Return Value

Boolean
True if the input ExternalGeometryId can be used to create a new correspondence.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also