IsPainted Method


Checks if the element's face is painted with a material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public bool IsPainted(
	ElementId elementId,
	Face face
)
Visual Basic
Public Function IsPainted ( _
	elementId As ElementId, _
	face As Face _
) As Boolean
Visual C++
public:
bool IsPainted(
	ElementId^ elementId, 
	Face^ face
)

Parameters

elementId
Type: Autodesk.Revit.DBElementId
The element that the face belongs to.
face
Type: Autodesk.Revit.DBFace
The painted element's face.

Return Value

True if the element's face is painted.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The element elementId does not exist in the document -or- The face doesn't belong to the element
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also