IsPainted Method


Document Is Painted Method

Checks if the element's face is painted with a material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsPainted(
	ElementId elementId,
	Face face
)

Parameters

elementId ElementId
The element that the face belongs to.
face Face
The painted element's face.

Return Value

Boolean
True if the element's face is painted.
Exceptions
Exception Condition
ArgumentException The element elementId does not exist in the document -or- The face doesn't belong to the element
ArgumentNullException A non-optional argument was null
See Also