Creates an empty family of a given category.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- importerIFC
- Type: Autodesk.Revit.DB.IFCImporterIFC
The importer.
- aDoc
- Type: Autodesk.Revit.DBDocument
The document to create the family.
- catId
- Type: Autodesk.Revit.DBElementId
The category id.
- familyName
- Type: SystemString
The family name.
Return Value
The created family id.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |