CreateEmptyFamily Method


Importer IFCUtils Create Empty Family Method

Creates an empty family of a given category.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId CreateEmptyFamily(
	ImporterIFC importerIFC,
	Document aDoc,
	ElementId catId,
	string familyName
)

Parameters

importerIFC ImporterIFC
The importer.
aDoc Document
The document to create the family.
catId ElementId
The category id.
familyName String
The family name.

Return Value

ElementId
The created family id.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also