Can be used to allow the server to execute only in certain views.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- dBView
- Type: Autodesk.Revit.DBView
The view where rendering will occur.
Return Value
True if the server can be executed in the provided view, false otherwise.Remarks
Execution of a DirectContext3D server means that the server is called upon to contribute a bounding box and graphics content (opaque and transparent) for an opened view. The following are some of the conditions that control whether the server is executed:
- The return value of this interface method.
- Whether the server is one of the active servers for the service.
- For servers that use DirectContext3D handles, the visibility of handle instances.