IDirect |
Can be used to allow the server to execute only in certain views.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- dBView View
- The view where rendering will occur.
Return Value
BooleanTrue if the server can be executed in the provided view, false otherwise.

Execution of a DirectContext3D server means that the server is called upon to contribute a bounding box and graphics content (opaque and transparent) for an opened view. The following are some of the conditions that control whether the server is executed:
- The return value of this interface method.
- Whether the server is one of the active servers for the service.
- For servers that use DirectContext3D handles, the visibility of handle instances.