SetLinkDataPath Method


Sets the Link data path owned by this LinkLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public void SetLinkDataPath(
	ModelPath linkPath
)
Visual Basic
Public Sub SetLinkDataPath ( _
	linkPath As ModelPath _
)
Visual C++
public:
void SetLinkDataPath(
	ModelPath^ linkPath
)

Parameters

linkPath
Type: Autodesk.Revit.DBModelPath
The Links data path set for this LinkLoadContent object.

Remarks

This path must be a location accessible to Revit. Revit will attempt to load the link from this location.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also