SetPlacementNumber Method


Sets Placement Number of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static void SetPlacementNumber(
	Document doc,
	ElementId refPointId,
	int placementNumber
)
Visual Basic
Public Shared Sub SetPlacementNumber ( _
	doc As Document, _
	refPointId As ElementId, _
	placementNumber As Integer _
)
Visual C++
public:
static void SetPlacementNumber(
	Document^ doc, 
	ElementId^ refPointId, 
	int placementNumber
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The Document
refPointId
Type: Autodesk.Revit.DBElementId
The ReferencePoint id
placementNumber
Type: SystemInt32
Placement number of the Adaptive Placement Point.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point. -or- The number placementNumber is out of range.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException This operation failed.

See Also