Adaptive |
Sets Placement Number of an Adaptive Placement Point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static void SetPlacementNumber(
Document doc,
ElementId refPointId,
int placementNumber
)
Parameters

Exception | Condition |
---|---|
ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point. -or- The number placementNumber is out of range. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This operation failed. |