Equals Method (StructuralAsset)


Determines whether this structural asset is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public bool Equals(
	StructuralAsset other
)
Visual Basic
Public Function Equals ( _
	other As StructuralAsset _
) As Boolean
Visual C++
public:
bool Equals(
	StructuralAsset^ other
)

Parameters

other
Type: Autodesk.Revit.DBStructuralAsset
The structural asset with which to compare this structural asset.

Return Value

True if the given structural asset is equal to this one, otherwise false.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also