ColorWithTransparency Constructor (UInt32, UInt32, UInt32, UInt32)


color

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public ColorWithTransparency(
	uint red,
	uint green,
	uint blue,
	uint transparency
)
Visual Basic
Public Sub New ( _
	red As UInteger, _
	green As UInteger, _
	blue As UInteger, _
	transparency As UInteger _
)
Visual C++
public:
ColorWithTransparency(
	unsigned int red, 
	unsigned int green, 
	unsigned int blue, 
	unsigned int transparency
)

Parameters

red
Type: SystemUInt32
red
green
Type: SystemUInt32
green
blue
Type: SystemUInt32
blue
transparency
Type: SystemUInt32
transparency

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The value is not valid. The valid range is 0 to 255.

See Also