Returns the necessary information to define a NURBS surface for a given [!:Autodesk::Revit::DB::HermiteSuface] or [!:Autodesk::Revit::DB::RuledSuface].
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- surface
- Type: Autodesk.Revit.DBSurface
The HermiteSurface or RuledSurface to be converted.
Return Value
A class containing the necessary data to define a NURBS surface.Remarks
This function is intended for export purposes.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This surface type is not supported for this function. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Couldn't get NURBS data from surface. |