GetNurbsSurfaceDataForSurface Method


Export Utils Get Nurbs Surface Data For Surface Method

Returns the necessary information to define a NURBS surface for a given [!:Autodesk::Revit::DB::HermiteSuface] or [!:Autodesk::Revit::DB::RuledSuface] .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static NurbsSurfaceData GetNurbsSurfaceDataForSurface(
	Surface surface
)

Parameters

surface Surface
The HermiteSurface or RuledSurface to be converted.

Return Value

NurbsSurfaceData
A class containing the necessary data to define a NURBS surface.
Exceptions
Exception Condition
ArgumentException This surface type is not supported for this function.
ArgumentNullException A non-optional argument was null
InvalidOperationException Couldn't get NURBS data from surface.
Remarks
This function is intended for export purposes.
See Also