CreateFromTopographySurface Method


Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public static Toposolid CreateFromTopographySurface(
	Document document,
	ElementId hostSurfaceId,
	ElementId topoTypeId,
	ElementId levelId
)
Visual Basic
Public Shared Function CreateFromTopographySurface ( _
	document As Document, _
	hostSurfaceId As ElementId, _
	topoTypeId As ElementId, _
	levelId As ElementId _
) As Toposolid
Visual C++
public:
static Toposolid^ CreateFromTopographySurface(
	Document^ document, 
	ElementId^ hostSurfaceId, 
	ElementId^ topoTypeId, 
	ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document in which the new toposolid is created.
hostSurfaceId
Type: Autodesk.Revit.DBElementId
Id of the host TopogarphySurface element.
topoTypeId
Type: Autodesk.Revit.DBElementId
Id of the toposolid type to be used by the new toposolid.
levelId
Type: Autodesk.Revit.DBElementId
Id of the level on which the toposolid is to be placed.

Return Value

A new toposolid object within the project if successful.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also