CreateFromTopographySurface Method


Toposolid Create From Topography Surface Method

Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Toposolid CreateFromTopographySurface(
	Document document,
	ElementId hostSurfaceId,
	ElementId topoTypeId,
	ElementId levelId
)

Parameters

document Document
The document in which the new toposolid is created.
hostSurfaceId ElementId
Id of the host TopogarphySurface element.
topoTypeId ElementId
Id of the toposolid type to be used by the new toposolid.
levelId ElementId
Id of the level on which the toposolid is to be placed.

Return Value

Toposolid
A new toposolid object within the project if successful.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also