Creates a new instance of a mechanical equipment set and adds it to the document.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document where the element will be created and added.
- typeId
- Type: Autodesk.Revit.DBElementId
The type of new mechanical equipment set.
- memberIds
- Type: System.Collections.GenericISetElementId
The member elements of this mechanical equipment set.
Return Value
The newly created mechanical equipment set.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Invalid mechanical equipment set type. -or- This mechanical equipment set needs at least two members. -or- The valid members must have the same classification and system. A valid member cannot be a member of any other existing set. -or- These elements are serially connected. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |