Create Method


Mechanical Equipment Set Create Method

Creates a new instance of a mechanical equipment set and adds it to the document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static MechanicalEquipmentSet Create(
	Document document,
	ElementId typeId,
	ISet<ElementId> memberIds
)

Parameters

document Document
The document where the element will be created and added.
typeId ElementId
The type of new mechanical equipment set.
memberIds ISet ElementId
The member elements of this mechanical equipment set.

Return Value

MechanicalEquipmentSet
The newly created mechanical equipment set.
Exceptions
Exception Condition
ArgumentException Invalid mechanical equipment set type. -or- This mechanical equipment set needs at least two members. -or- The valid members must have the same classification and system. A valid member cannot be a member of any other existing set. -or- These elements are serially connected.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also