ServerSupportsCADLinks Method


Checks that the server referenced by the given ExternalResourceReference supports CAD links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public static bool ServerSupportsCADLinks(
	ExternalResourceReference extRef
)
Visual Basic
Public Shared Function ServerSupportsCADLinks ( _
	extRef As ExternalResourceReference _
) As Boolean
Visual C++
public:
static bool ServerSupportsCADLinks(
	ExternalResourceReference^ extRef
)

Parameters

extRef
Type: Autodesk.Revit.DBExternalResourceReference
The ExternalResourceReference to check.

Return Value

True if the ExternalResourceReference refers to a server that supports CAD links. False otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also