AreCoordinatesInBounds Method


Determines whether given coordinates are within the bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public bool AreCoordinatesInBounds(
	RepeaterCoordinates coordinates,
	bool treatCyclicalBoundsAsInfinite
)
Visual Basic
Public Function AreCoordinatesInBounds ( _
	coordinates As RepeaterCoordinates, _
	treatCyclicalBoundsAsInfinite As Boolean _
) As Boolean
Visual C++
public:
bool AreCoordinatesInBounds(
	RepeaterCoordinates^ coordinates, 
	bool treatCyclicalBoundsAsInfinite
)

Parameters

coordinates
Type: Autodesk.Revit.DBRepeaterCoordinates
The coordinates.
treatCyclicalBoundsAsInfinite
Type: SystemBoolean
True if cyclical directions should be treated as unbounded.

Return Value

True if the coordinates are within the bounds.

Remarks

The coordinates must have the same number of dimensions as the bounds. This method does not apply to zero dimensional bounds.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The coordinates coordinates have incompatible number of dimensions.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The bounds must have at least one dimension.

See Also