AreCoordinatesInBounds Method


Repeater Bounds Are Coordinates In Bounds Method

Determines whether given coordinates are within the bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool AreCoordinatesInBounds(
	RepeaterCoordinates coordinates,
	bool treatCyclicalBoundsAsInfinite
)

Parameters

coordinates RepeaterCoordinates
The coordinates.
treatCyclicalBoundsAsInfinite Boolean
True if cyclical directions should be treated as unbounded.

Return Value

Boolean
True if the coordinates are within the bounds.
Exceptions
Exception Condition
ArgumentException The coordinates coordinates have incompatible number of dimensions.
ArgumentNullException A non-optional argument was null
InvalidOperationException The bounds must have at least one dimension.
Remarks
The coordinates must have the same number of dimensions as the bounds. This method does not apply to zero dimensional bounds.
See Also