IsWorksetNameUnique Method


Checks if the given workset name is unique in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015 Subscription Update

Syntax

C#
public static bool IsWorksetNameUnique(
	Document aDoc,
	string name
)
Visual Basic
Public Shared Function IsWorksetNameUnique ( _
	aDoc As Document, _
	name As String _
) As Boolean
Visual C++
public:
static bool IsWorksetNameUnique(
	Document^ aDoc, 
	String^ name
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
The document in which the workset is accessed.
name
Type: SystemString
The workset name.

Return Value

True if this given workset name is unique in the document, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also