Assign a new list of constraints to this segment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- constraints
- Type: System.Collections.GenericIListRebarShapeConstraint
A new list of constraints.
Remarks
Any existing constraints are discarded. The new constraints replace them. Any parameters driving the constraints must already be added with RebarShapeDefinition.AddParameter().
The allowable constraint types are:
- RebarShapeConstraintAngleFromFixedDir
- RebarShapeConstraintSegmentLength
- RebarShapeConstraintFixedSegmentDir
- RebarShapeConstraintProjectedSegmentLength
- RebarShapeConstraint180DegreeBendArcLength
- RebarShapeConstraint180DegreeBendRadius
- RebarShapeConstraint180DegreeDefaultBend
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | One or more of the constraints is of a type not supported for RebarShapeSegment. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |