Rebar |
Assign a new list of constraints to this segment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- constraints IList RebarShapeConstraint
- A new list of constraints.

Exception | Condition |
---|---|
ArgumentException | One or more of the constraints is of a type not supported for RebarShapeSegment. |
ArgumentNullException | A non-optional argument was null |

Any existing constraints are discarded. The new constraints replace them. Any parameters driving the constraints must already be added with RebarShapeDefinition.AddParameter().
The allowable constraint types are:
- RebarShapeConstraintAngleFromFixedDir
- RebarShapeConstraintSegmentLength
- RebarShapeConstraintFixedSegmentDir
- RebarShapeConstraintProjectedSegmentLength
- RebarShapeConstraint180DegreeBendArcLength
- RebarShapeConstraint180DegreeBendRadius
- RebarShapeConstraint180DegreeDefaultBend