VertexFormat Constructor


Constructs the specification of vertex format from a numerical representation.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public VertexFormat(
	VertexFormatBits vertexFormatBits
)
Visual Basic
Public Sub New ( _
	vertexFormatBits As VertexFormatBits _
)
Visual C++
public:
VertexFormat(
	VertexFormatBits vertexFormatBits
)

Parameters

vertexFormatBits
Type: Autodesk.Revit.DB.DirectContext3DVertexFormatBits
The numerical representation of the vertex format.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException This VertexFormat is not available because Revit is not currently rendering. In general, this VertexFormat must be used in the scope of the RenderScene() callback of IDirectContext3DServer.

See Also