Vertex |
Constructs the specification of vertex format from a numerical representation.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- vertexFormatBits VertexFormatBits
- The numerical representation of the vertex format.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
InvalidOperationException | This VertexFormat is not available because Revit is not currently rendering. In general, this VertexFormat must be used in the scope of the RenderScene() callback of IDirectContext3DServer. |