Create Method (Document, String, Guid, String, ElementId)


Creates a new StructuralConnectionHandlerType object.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static StructuralConnectionHandlerType Create(
	Document pADoc,
	string name,
	Guid guid,
	string familyName,
	ElementId categoryId
)
Visual Basic
Public Shared Function Create ( _
	pADoc As Document, _
	name As String, _
	guid As Guid, _
	familyName As String, _
	categoryId As ElementId _
) As StructuralConnectionHandlerType
Visual C++
public:
static StructuralConnectionHandlerType^ Create(
	Document^ pADoc, 
	String^ name, 
	Guid guid, 
	String^ familyName, 
	ElementId^ categoryId
)

Parameters

pADoc
Type: Autodesk.Revit.DBDocument
The document.
name
Type: SystemString
The type name.
guid
Type: SystemGuid
Connection GUID.
familyName
Type: SystemString
Name of system family which created type will belong to.
categoryId
Type: Autodesk.Revit.DBElementId
Category identity of connection type.

Return Value

The newly created instance.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also