Structural |
Creates a new StructuralConnectionHandlerType object.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static StructuralConnectionHandlerType Create(
Document pADoc,
string name,
Guid guid,
string familyName,
ElementId categoryId
)
Parameters
- pADoc Document
- The document.
- name String
- The type name.
- guid Guid
- Connection GUID.
- familyName String
- Name of system family which created type will belong to.
- categoryId ElementId
- Category identity of connection type.
Return Value
StructuralConnectionHandlerTypeThe newly created instance.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |